Having trouble Accessing GSN Help?

Having trouble accessing Help? Beginning June 14, 2018, all players must use an up-to-date browser to successfully access GSN Help.

These browsers will continue to be supported:
Internet Explorer 11+, Microsoft Edge 12+, Firefox 27+, Chrome 30+, Safari 7+, iOS Safari 7+, Opera Mini 17+, Chrome for Android 30+, UC Browser for Android 11.8+, Samsung Internet 4, 6.2+.

Not sure what browser/version you have? Go here.

Leave a Reply

Your email address will not be published. Required fields are marked *